I just saw an article on Phoronix that Team Fortress 2 got a big update to the OpenGL renderer. The update includes support for Texture Streaming over OpenGL, which apparently reduces VRAM usage considerably and brings it in line with the Direct3D 9 Renderer. Sounds like this is exactly the reason so much more VRAM is used on Linux. Any chance you guys are going to ever get this code?
http://www.phoronix.com/scan.php?page=ne...rer-Update
Reply
On an Nvidia 550 ti with 1GB VRAM, tried 352.*, 355.*, 358.* drivers on my Gentoo box. No real difference in driver performance for Insurgency on my box.

I discovered I can run everything exactly as on Windows with the exception of shaders, which I have on medium. I lose cosmetic parts of the skybox (didn't notice until someone pointed this out) and the fancy lighting on the weapon in first-person, but otherwise it looks pretty much identical to Windows. Shader is the one setting that makes the difference for me.

Using nvidia-smi I ran it using the loop option with different shader configs and concur it is definitely VRAM filling up that causes the tank in FPS, specifically running shaders on high most of all. Textures help, but they're not as significant as shaders. With medium shaders VRAM runs around 80-90%, and I think caching is not affecting performance at this number; at high shaders VRAM is maxed and FPS goes to single digits, presumably as cache bandwith cannot keep up.

I can live with it until I bother upgrading the GPU, God knows when that will be...
Reply
I was referred to this thread from the Steam community.
I am running Fedora 23 with Gnome 3.18. I'm trying gaming for the first time on Steam. I was able to install the Steam client with no issues using Fedy. Steam launches and all is well. I was also able to install Insurgency with no issues. When I launched Insurgency for the first time I got the OpenGL error message I have seen others post. I was able to proceed and the game launched. I then proceeded to join a server I have played many times from my Favorites but the map download hangs. I tried this on several attempts for various maps on the same server and others, all with the same result, download starts then hangs. Sometimes a quarter through the download process sometimes all the way through just before starting the game.
I would really love to play this game on my Fedora build without having to reboot into my Windows 10 build that I use for gaming as I am always in Fedora for my day-to-day computing and prefer to use Linux over Windows.
Here are my specs:

Asus Z97-AR
Intel i5-4690K
Nvidia GeForce GTX 970
16GB RAM DDR3 2400
Samsung 840 SSD

I'm running the proprietary Nvidia drivers version 352.63.

inxi -G
Graphics:  Card: NVIDIA GM204 [GeForce GTX 970]
          Display Server: Fedora X.org 118 driver: nvidia
          Resolution: [email protected], [email protected]
          GLX Renderer: GeForce GTX 970/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 352.63

Any assistance on trying to get Insurgency running completely without flaws would be greatly appreciate.
Reply
So i don't know where should i report issues with linux client here or recently opened https://forums.newworldinteractive.com/thread-3893.html

So i decided that i'll post here. I have the same small issue as the guy on the link above. The white box in the left top corner is slightly annoying. Super annoying is the crashing of the client.

Hardware to reproduce the bug:
- 1 screen with 4:3 (1280x1024)
- 1 screen with 16:9  (1920x1080) - TV connected via HDMI

When i turn my TV on and turn it off after i'm not using it anymore 'xrandr' still reports it as 'connected'. Why is this important you ask? Well it is important because when i start Insurgency it shows the splash screen (bug #1 or is it #2?) which means its in 16:9 mode. Otherwise (4:3) the splash screen is not shown.(bug #2.5?)
So the next logical step would be to change the ratio settings right? Of course. We change it back to 4:3, click Apply and all is good again BUT WAIT! Bug #3 is here, advanced video settings are all on High which my lil' APU can't handle. So now we need to change them back to medium/low and hit Apply again. No crash for now until ... we click on Server browser. Bug #4, our client crashes.

Using Ubuntu 14.04 with radeon drivers (opensource drivers).

Other than that the game works as a charm. Kudos for porting to Linux.
Reply
This game crashes for me nearly every time I start it. It almost always happens at the main menu or the game selection menu. If I try 3-4 times, eventually it will not crash. It also crashes if I Alt-Tab out of the game and then back into the game. I have 29 dump files. Are these auto-uploaded or would you like me to upload them somewhere?

Debian/stretch w/ nvidia GTX 465. Many of the crashes happen in the nvidia driver but no other games crash for me. Here's the segfault lines from dmesg:

Code:
[937179.031898] insurgency_linu[10223]: segfault at 0 ip           (null) sp 00000000ba5b527c error 14 in insurgency_linux[8048000+1000]
[937208.944920] insurgency_linu[10242]: segfault at 4 ip 00000000f62080ff sp 00000000f49e1510 error 4 in libnvidia-glcore.so.340.93[f4d23000+18ea000]
[939187.403213] insurgency_linu[11600]: segfault at 4 ip 00000000f61af0ff sp 00000000f4988510 error 4 in libnvidia-glcore.so.340.93[f4cca000+18ea000]
[939200.445258] insurgency_linu[11638]: segfault at 4 ip 00000000f61ab0ff sp 00000000f4984510 error 4 in libnvidia-glcore.so.340.93[f4cc6000+18ea000]
[944832.397458] insurgency_linu[31510]: segfault at 0 ip           (null) sp 00000000bacb127c error 14 in insurgency_linux[8048000+1000]
[944846.295806] insurgency_linu[16026]: segfault at 4 ip 00000000f62360ff sp 00000000f4a0f510 error 4 in libnvidia-glcore.so.340.93[f4d51000+18ea000]
[997645.443660] insurgency_linu[5883]: segfault at 0 ip           (null) sp 00000000b733027c error 14 in insurgency_linux[8048000+1000]
Reply
The command interface still doesn't work properly, if you open it, you can't close it anymore and you also can't select the commands. You have to wait until you die or open the game console kill yourself.
Also I still sometimes get a white square in the top left corner, not sure what's up with that.
Otherwise it works flawlessly, even Day of Infamy. Good job guys!
Reply
A few pages back in this thread someone said assigning console toggle to F9 worked for them, but I can't open the console at the main menu no matter what key it's assigned to.

Any ideas?

Thanks.

Ubuntu Mate 15.10 x64
kernel 4.2.0-30-generic
GTX 960 4gb
Proprietary Nvidia driver 352.63
xorg 1.17.2 (11702000)
NV-CONTROL version 1.29
Reply
I think you have to enable the option "Developer Console" in the gameplay options IIRC.
Reply
(02-03-2016, 19:45)HeavyHDx Wrote: I think you have to enable the option "Developer Console" in the gameplay options IIRC.

Console is set to Enable under Settings/Game

...EDIT...

I switched it to disabled, then back to enabled, and it works now. Thanks.
Reply
Command rose is still broken, random crashes and a white square in the top left corner happen for me. Anyone else getting this too?

Here's a random screenshot where the white box can be seen:

http://i.imgur.com/doaCZch.png

I attached the dump from my most recent crash. Hopefully those are useful now. These crashes really discourage me from even starting up the game anymore, but I'm not sure what's causing them. Any ideas?

My system for reference (got a new PC)

Code:
System:    Host: heavy-pc Kernel: 4.5.0-1-ARCH x86_64 (64 bit gcc: 5.3.0)
           Desktop: KDE Plasma 5.5.5 (Qt 5.6.0) Distro: Arch Linux
Machine:   Mobo: Intel model: DP67BG v: AAG10491-306
           Bios: Intel v: BGP6710J.86A.2209.2012.0717.2302 date: 07/17/2012
CPU:       Quad core Intel Core i5-2500 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 26355
           clock speeds: max: 4100 MHz 1: 1761 MHz 2: 1644 MHz 3: 1788 MHz
           4: 1796 MHz
Graphics:  Card: NVIDIA GK106 [GeForce GTX 660] bus-ID: 01:00.0
           Display Server: X.Org 1.18.2 driver: nvidia
           Resolution: [email protected], [email protected]
           GLX Renderer: GeForce GTX 660/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 361.28 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GK106 HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.5.0-1-ARCH
Network:   Card: Intel 82579V Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 2040 bus-ID: 00:19.0
           IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1120.2GB (61.6% used)
           ID-1: /dev/sda model: Samsung_SSD_840 size: 120.0GB
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB
Partition: ID-1: / size: 110G used: 95G (91%) fs: ext4 dev: /dev/sda3
           ID-2: /boot size: 512M used: 26M (5%) fs: vfat dev: /dev/sda1
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A gpu: 0.0:35C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 169 Uptime: 2:16 Memory: 2103.0/7970.2MB
           Init: systemd Gcc sys: 5.3.0 Client: Shell (bash 4.3.421) inxi: 2.2.35 
Thanks guys.


Attached Files
.zip   dump.zip (Size: 39.33 KB / Downloads: 0)
Reply
Another crash after three or four matches. Attached dump file and entire console log from launching Steam to the crash.

Edit:

Unsubscribed from all Workshop mods and reinstalled the game, problems still present.


Attached Files
.zip   crash.zip (Size: 56.02 KB / Downloads: 1)
Reply
I think I've narrowed it down to this setting in the NVIDIA drivers:

http://i.imgur.com/2pmVe5T.png

AFAIK it is enabled by default. When I disable it, I don't seem to get any crashes anymore.

Problem is that disabling it also seems to cause weird texture and shadow behavior:

http://i.imgur.com/XNfHt0M.png

Distant textures seem to fight over who's on top, resulting in distracting flickering.

Again, I'm not really sure if I'm the only one experiencing this, so if others could test it, I'd appreciate it.

Attached another crash log. Btw this is on a fresh Arch install with thee latest 364.12 NVIDIA Drivers.

Edit: it seems to be related to the smooth particles setting in game. I disabled that and now it doesn't crash anymore, regardless of driver settings.


Attached Files
.zip   crash.zip (Size: 15.72 KB / Downloads: 1)
Reply
I'm getting random crashes on joining servers. No particular servers that I can tell.

OS: Linux Mint 17.2 x64
DE: Gnome Classic
NVIDIA 340.96 Drivers

Unsubscribed to Workshop Content. Still have the problem.

Here's the console stdout


Please advise. Thanks for the Linux support!
Reply
Hello!

I have a problem running Insurgency in my computer:
-Ubuntu 16.04 LTS 64-bit
-Intel i7-4702MQ
-8 GB RAM
-Intel HD 4600 graphic integrated video card.

The problem is that every time I try to join a server the game crashes and closes just before finishing loading. After that  I have to kill the process. I have found that if I enter to the solo mode (the tutorial) before trying to join a server, and stay there for a while, then go back to the main menu and try to join a server everything works perfect. I don't have any problem doing this, but may be it can be fixed. I have tried steam cache game integrity, and disable steam overlay while in-game. But it doesn't seem to be the problem.

Thanks for making a Linux version and support it.

PD: Maybe .dmp helps.


.zip   crash.zip (Size: 100.15 KB / Downloads: 0)
Reply




Users browsing this thread: 1 Guest(s)