#1
I always ran around 100-140 FPS on DOI. Their were no game updates laltely but I got a new driver update for my Graphics card. At first I was getting random Black screens that lasted 3 seconds every 3 minutes and then the game would come back again. Made sure all the drivers were updated and still had the problem.

Decided to reformat my computer and I no longer get the Black screens but now my game goes from 100 FPS down to 20-15 FPS. Made sure I downloaded all the drivers but I'm still having issues. Blacks screens gone but now I get dramatic FPS drop on DOI.

I understand the game was poorly optimized but I never had a problem with this game until the past 4 days and I had this game since January. Totally lost on what to do but my other games work perfectly fine. HELP!

CPU: Intel i7 6700K 4.0 Ghz
GPU: EVGA GTX 1070 8GB FTW
SSD: Samaung 950 Pro 512 GB
MB: Gigabyte Z170X-Gaming 7
Reply
#2
Same issue here. Bought the game awhile ago, always played fine. 300 fps constant.

Now, it's around 15-40, depending on smoke or artillery.

I have a 7700k and a 1080 ti.
CPU and GPU aren't reaching very high usage, they're not overheating, latest clean install of drivers have been installed, in-game settings make close to no difference at all, autoexecs, configs, jumbled with various applicable settings in nvidia control panel, etc.

Other Source games run just fine.

I've tried many things and nothing's worked. All I can do at this point is make a post about it.
Reply
#3
(10-05-2017, 22:03)Scrib Wrote: Same issue here. Bought the game awhile ago, always played fine. 300 fps constant.

Now, it's around 15-40, depending on smoke or artillery.

I have a 7700k and a 1080 ti.
CPU and GPU aren't reaching very high usage, they're not overheating, latest clean install of drivers have been installed, in-game settings make close to no difference at all, autoexecs, configs, jumbled with various applicable settings in nvidia control panel, etc.

Other Source games run just fine.

I've tried many things and nothing's worked. All I can do at this point is make a post about it.

I'm thinking it might be the new Driver update for Nvidia because I only had these problems in the last couple of days. That's about the same time the new drivers for Nvidia cards come out. I don't know though.
Reply
#4
So I might have found a fix! For some reason when I updated my drivers to my computer it changed the Power Management to optimal.

Go to Nvidia Control Panel, Manage 3D settings on the left, look for "Power Management Mode", and I changed it to "Prefer Maximum Performance". Everything is running max and my game goes from 144 fps to 50 fps depending on whats going on.
Reply
#5
One of the first things I tried, unfortunately for me.

I still get very bad performance.

FPS Count at top left of image. The game is unplayable, which really sucks because the game is super fun.
http://i.imgur.com/uXP5L7F.jpg
Reply
#6
I would say call the manufacturer of your GPU. I called EVGA and thats what they told me to do, not sure if the right but my game is staying constant around 144 to 70 FPS
Reply
#7
Actually, I'm still getting FPS drops, even after going to earlier Nvidia drives. After, much research, and 5 days of reinstalling drivers, changing settings, and reformatting my computer. According to the Nvidia Forums it has to do with the new Nvidia drivers and Windows 10 creator. Somehow Windows and Nvidia need to find a way where the new drivers works with the Windows 10 creator update. Until then, we are at the mercy of Windows and Nvidia. I have been getting frame drops in all my games, I just haven't noticed because I play DOI mostly.
Reply




Users browsing this thread: 1 Guest(s)